Plugins in Callibre hinzufügen.

      till schrieb:

      Hallo, ich versuche seit Stunden die Plugins zu installieren, aber ich bekomme jedesmal ne Fehlermeldung das die Plugins nicht unterstüzt werden, auch nicht wenn ich Callibre als admin starte. Was mache ich falsch? ?(
      Welche Fehlermeldung? Wäre nicht schlecht wenn du die posten könntest....
      Plugins (Alf) für Calibre nötig?? (siehe mein Profil ) "DRM ist böse" Youtube

      Basstom schrieb:

      Aber hier ist ein gezieltes Antworten kaum möglich, da einfach Infos fehlen.
      So ist es, Man müsste wiesen um welche Plugins es geht oder zumindest welche Fehlermeldung. Neben dem entpacken der Plugins gibt es noch den gegengesetzen Fehler. Manchmal bekommt Plugins im Paket und dass sind dann natürlich Zip-Dateien=Plugins die noch mal gezippt wurden. Und die muss man halt dann einmal entpacken.. sonst kann Calibre das nicht lesen...
      Plugins (Alf) für Calibre nötig?? (siehe mein Profil ) "DRM ist böse" Youtube
      Hast du eventuell eine ältere Version von Calibre instaliert? Bei mir gab es auch mal ein Problem bei der Installation von Plugins, aber nach Installation der neueren Version hat es dann funktioniert.
      Hallo, Danke für die vielen Antworten. Also meine Callibre Version lautet 08.24. von Kovid Goyal und von den Plugins habe ich die Version "tools v4.8 tools". Ich habe versucht Sie einzeln als Zip oder halt gleich komplett als Zip zu installieren. Jedesmal kommt dann aber zB. diese Fehlermeldung:


      calibre, version 0.8.24
      ERROR: Nicht abgefangener Fehler: InvalidPlugin:The plugin in u'C:/Users/sven/Desktop/tools_v4.8/tools_v4.8/DeDRM_for_Mac_and_Win/DeDRM_3.1.app.zip' is invalid. It does not contain a top-level __init__.py file

      Traceback (most recent call last):
      File "site-packages\calibre\gui2\preferences\plugins.py", line 290, in add_plugin
      File "site-packages\calibre\customize\ui.py", line 339, in add_plugin
      File "site-packages\calibre\customize\ui.py", line 54, in load_plugin
      File "site-packages\calibre\customize\zipplugin.py", line 160, in load
      File "site-packages\calibre\customize\zipplugin.py", line 255, in _locate_code
      InvalidPlugin: The plugin in u'C:/Users/sven/Desktop/tools_v4.8/tools_v4.8/DeDRM_for_Mac_and_Win/DeDRM_3.1.app.zip' is invalid. It does not contain a top-level __init__.py file


      ?(
      Du musst die ZIP-Dateien aus dem Ordner "Calibre_Plugin" nehmen. Das andere ist eine eigenständiges Programm, das ohne Calibre läuft.

      p.s.: Dieser Beitrag ist mit einer Selbstzerstörung versehen und vernichtet sich in wenigen Stunden aus rechtlichen Gründen selbst.
      Tja sowas hatte ich befürchtet.... Warum nehmen die Leute nicht einfach das wo "Calibre Plugins draufsteht....

      PS:
      Dieser Beitrag bleibt aus moralischen Gründen, die über den rechtlichen stehen stehen...
      Plugins (Alf) für Calibre nötig?? (siehe mein Profil ) "DRM ist böse" Youtube

      till schrieb:

      :huh: man bin ich bekloppt, aber manchmal sieht man den Wald vor lauter Bäumen nicht... Danke noch einmal!

      till schrieb:

      Huhuuuuu, ich bin neu hier und sehe wirklich den Wald vor lauter Bäumen nicht, ich habe das Problem auch wie oben beschrieben und hab es gerade gegoogled und bin auf die Seite hier gekommen... das Problem ist, wenn ich auf meine Downloads gehe dann kann ich das öffnen bis zu dem k..., aber wenn ich auf load plugin from file gehe kann ich dann auf den zip 5.1 gehen aber es kommt direkt die Sicherheitsfrage, also ich kann die zipdatei nicht weiter öffnen um zum Calibre zip zu kommen, ich krieg hier noch nen AAAAAAnfaaaaallllll ;( bin ich denn so blond oder wieso klappt das nicht,... ???? ?( 8| ...kann mir irgendjemand helfen?! ich versuchs schon seit Ewigkeiten,... vielleicht hab ich ja auch nen Denkfehler irgendwo?! Geh über Safari rein, hat das was damit zu tun?! Wegen dem Java!??? weil mein Internet explorer nicht mehr richtig funzt???? Irgendjemand eine Idee??????? Vielen Daaaaaaaank :thumbsup:
      So ich hab wieder ein Plugin vorzustellen: Wiki Reader

      Das Plugin erstellt auch Wikipedia-Artikeln ein Ebook. Es ist recht simpel aufgebaut. Man gibt einen Titel für das Ebook und die Link zu den Artikeln bei Wikipedia ein.
      Das Ergebnis kann sich sehen lassen. Das erstellte Ebook erhält ein entsprechendes Cover und auch ein super Inhaltsverzeichnis. Nur die Bilder und Bildunterschriften sind im Ebook nicht zentriert, sondern rechtsbündig. Außerdem sind die Karten viel zu klein und eine vergrößerte Version wird leider nicht mitgespeichert (oder falsch verlinkt). Außerdem kann man mit den Links auf Wikipedia offline nicht so viel anfangen. Aber das ist Meckern auf hohem Niveau. Ich finde es gut!
      Plugins (Alf) für Calibre nötig?? (siehe mein Profil ) "DRM ist böse" Youtube
      Schon hätte ich einen Verbesserungsvorschlag:

      Die kompletten URLs einzugeben ist etwas umständlich. Da die Syntax immer gleich ist, müsste es doch möglich sein, die Sprache der Wikipedia auszuwählen und dann nur noch die Lemmata ins untere Feld einzusetzen. Die Umwandlung von Leerzeichen, Umlauten usw. folgt auch festen Regeln. Das sollte sich alles ins Plugin einbauen lassen.

      Dann wäre es so richtig super.
      Und genial würde es, wenn man auch noch Kategorien auswählen könnte: "Sammle alle Artikel aus Kategorie X und ihren Unterkategorien."

      Und noch ne Idee: In der Wikipedia kann man ja Artikel zu Büchern zusammenstellen, die dann als PDFs ausgegeben werden. Das müsste sich doch mit überschaubarem Aufwand auf Epub als Ausgabeformat erweitern lassen.
      Gute Ideen, werde das im Mobileread mal vorschlagen. Hab gerade gesehen, dass ich den Beitrag im falschen Thread geschrieben habe. Werde es noch mal im richtigen einfügen.

      Update:
      So hier hab ich den Beitrag im richtigen Faden:
      Calibre Plugins: Vorschläge, Tipps und Beschreibungen hier rein
      Plugins (Alf) für Calibre nötig?? (siehe mein Profil ) "DRM ist böse" Youtube
      Ich nehme an, du hast mittlerweile die neue Version von Kindle for PC drauf und die Plugins sind nicht mehr kompatibel. Suche nach tools_v5.1.zip, da ist das neue AZW-Plugin drin.
      Jeder soll nach seiner Façon selig werden lesen. (frei nach Fritz II)
      Ruhe Alfen ist die erste Bürgerpflicht. (frei nach Graf v. d. Schulenburg, 1806)
      Danke für die Antwort.

      ja, ich habe den neuen K4PC, habe aber gestern die Plug in version Zip 5.1 installiert. Übrigens nachdem ich auch die letzte Calibre-Version installiert habe.

      Trotzdem immer die gleiche Meldung beim importieren nach Calibre. Hat niemand sonst das Problem??
      Dann hab ich wohl was falsch gemacht

      Dinu schrieb:

      Dann hab ich wohl was falsch gemacht

      Schwierig einzuschätzen. Schau mal in "Calibre-Einstellungen-Plugins-Eingabe der Konvertierung Plugins", ob dort "AZW4 Input (1.0.0)..." aufgeführt ist. Wenn nicht, ist was schiefgegangen. Wenn ja ... keine Ahnung. 8|
      Jeder soll nach seiner Façon selig werden lesen. (frei nach Fritz II)
      Ruhe Alfen ist die erste Bürgerpflicht. (frei nach Graf v. d. Schulenburg, 1806)
      OK Fehler gefunden, war meine eigene Dummkeit. Ist aber schnell passiert, daher hier wie es dazu kam.

      Ich hatte plug-in 5.01 zwar runtergeladen und auch entpackt.
      Als ich aber Calibre- Einstellungen- Plugins- aus Datei laden ausgeführt habe,
      öffnete Calibre den Letzten Ordner aus dem plug-ins instaliert wurden
      also (natürlich) nicht den in den ich meine neu runtergeladenen entpackt hatte....

      Ich hatte also die alten plug-ins neu installiert, und dachte es wäre 5.01....

      Für die Zukunft weiss ichs jetzt.
      Danke allen für die Hilfe!