Epub in Mobi umwandeln in Calibre

      Epub in Mobi umwandeln in Calibre

      Ich setze das mal ins Kindle Forum, da es für mich direkt mit dem Kindle zu tun hat.

      Ich habe zwei ePub Ebooks, DRM frei. Diese habe ich gestern Abend mit calibre in Mobi umgewandelt und auf meinen Kindle geschickt.
      Auf dem Kindle wird der Text aber nur auf der rechten Bildschirmseite angezeigt. Links bleibt es weiß.
      Es fehlen keine Buchstaben oder so, nur der Rand ist so gigantisch groß... fast die Hälfte des Bildschirms.

      Hat jemand Erfahrung mit dem umwandeln und könnte mir dabei helfen herauszufinden, was da schief gelaufen ist und wie ich das ändern kann?

      Auf meinem anderen Reader läuft das ePub einwandfrei, ohne diesen breiten Rand.
      wie sieht das epub grundsätzlich aus wenn du es in dem viewer von calibre betrachtest? sind die ränder da vielleicht schon drin? ich persönlich hatte noch kein eines problem mit einem zu mobi konvertierten epub... das ergebnis ist immer wie das original. wie sehen die mobi einstellungen in calibre aus, sind diese vielleicht sind standard bzw. nicht auf den kindle optimiert?
      lso, ich habe es jetzt nochmal probiert. Ich habe die Einstellungen jetzt mal insoweit geändert, indem ich das Kindle Format ausgewählt habe.
      Ich habe also die Datei zum wandeln gewählt, mobi angegeben und dann das Kindle Format.
      Mehr habe ich nicht geändert.
      Es ist ein bisschen besser geworden. Aber noch nicht perfekt.

      Auch die anderen Einstellungen haben nichts gebracht (am Kindle Schriftgröße o.ä.)

      Ich denke, die beiden Bücher klappen nicht richtig. Wahrscheinlich geht es nicht besser...


      EDIT: Es ist in der Vorschau schon zu sehen. Die Vorschau der mobi Datei dauert auch ewig in calibre zu öffnen. Während die ePub Variante viel schneller geht.
      Ich habe ein epub zu mobi umgewandelt und auch links eine größeren Rand. Allerdings nur ca. 1 cm mehr als rechts. Das ist noch zu tollerieren. Habe mehrere Versuche mit Calibre gemacht. Zunächst Basiseinstellung Kindle und dann versucht die Ränder zu verändern. Das hatte keine Auswirkung.
      Auf dem PC das Buch in Mobi anzeigen hat ewig gedauert und dann war kein Rand zu sehen!
      Habe leider keine Lösung gefunden. Aber geteiltes Leid ist halbes Leid ;)
      Voschlag: lese im Querformat. Da fällt der Rand vielleicht weniger auf.
      DRM? Was ist das?
      Hi,

      eventuell hilft es ja, wenn man in Calibre "epub bearbeiten" (Taste "t") auswählt.
      In dem sich öffnenden Fenster "explode ePub" wählen. (Fenster offen lassen)
      Dann werden die einzelnen Seiten der epub Datei angezeigt. Es müsste auch eine Datei "stylesheet.css" enthalten sein. Am Besten jetzt eine Sicherheitskopie dieser Datei anlegen.
      Dann die Datei "stylesheet.css" mit dem Editor öffnen (rechte Maustaste->öffnen mit...->Editor) und nach "margin-left:" Ausschau halten. Hinter dem Doppelpunkt steht eine Zahl. Diese Zahl beschreibt, wieviele Pixel Abstand zum linken Rand frei bleiben sollen. Diesen kann man nach Belieben ändern. (Es kann sein, dass mehrere dieser Werte existieren. Das bedeutet, dass für verschiedene Darstellungen (Fettdruck, Schrägschrift, Überschriften, usw.) verschiedene Vorgaben existieren.
      Daher kann es sein dass man etwas rumprobieren muss bis man den richtigen Wert gefunden hat.

      Das gleiche gfindet man auch für die anderen Ränder.

      Nach der Änderung die Datei wieder schließen, speichern und in Calibre "Rebuild ePup" anklicken. Jetzt kann man überprüfen, ob einem diese Einstellung gefällt, oder noch weiter optimieren muss.


      Will man die Änderungen auch im mobi-File sehen, dass muss man wieder neu konvertieren.



      Bratzzo
      "Am Ende wird alles gut! Wenn es nicht gut wird, ist es noch nicht das Ende." Oscar Wilde
      Diese Signatur wurde bereits 59 mal bearbeitet, zuletzt von »Bratzzo« (Heute, 00:23:59)
      @Bratzzo Danke für die Hilfe!
      Konnte die Style Datei lokalisieren. Zunächst habe ich die Margin left: 33px bei Buch auf 10px gesetzt. Dann rebuild epub. Mobi convertiert, auf den Kindle geladen. War die neue Datei, da wieder am Anfang gestartet ...

      Leider keine Änderung.

      Dann nochmals und jetzt bei Inhalt, Autor usw. überall die 33px auf 10 px gesetzt. Leider danach auch keine Änderung.

      Irgendein Hinweis wo noch was zu drehen geht? Evtl. an der Ausrichtung Mittig oder so?
      Oder evtl. die Werte Margin left auf 0em setzen? (was auch immer das bedeutet). Werde da mal herumexperimentieren.
      Das hat auch nicht funktioniert.
      Allerdings ist das nur bei einem Buch, nur ca. 1cm, also zu verkraften und eh schon über 70% gelesen.
      Wenn man weis wo zu ändern ist, dann müsste es gehen. Evtl. bei der Textausrichtung (Align: Centre, left, right).

      Denke dennoch Bratzzo, war auf jeden Fall ein guter Hinweis.

      Calibre ist einfach genial!
      DRM? Was ist das?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Helgetus“ ()

      Hi,

      Irgendein Hinweis wo noch was zu drehen geht? Evtl. an der Ausrichtung Mittig oder so?

      schade, dass es nicht funktioniert hat.
      Jetzt würde mich aber interessieren, um welches Buch es sich handelt. :D
      Da ich das gerne mal "live" sehen würde.

      Hast Du schon mal versucht die kindleeigene Voreinstellung der Randabstände zu ändern? Mich hat beim Kindle immer der recht große ungenutzte Bereich am linken und rechten Rand gestört (trotz der Einstellung "default" in "Words per Line"). Dann bin ich auf folgenden Hinweis (im Nachbarforum) gestoßen und habe jetzt mehr genutzten Textbereich:

      - beim Kindle auf den Homescreen wechseln
      - den Kindle mit dem PC verbinden
      - in den Ordner "com.amazon.ebook.booklet.reader" wechseln, der sich im Ordner "system" befindet [der Ordner ist versteckt- entweder auf dem PC versteckte Dateien anzeigen lassen, oder über die Suche nach versteckten Dateien suchen]
      - dort von der Datei "reader.pref" eine Sicherheitskopie erstellen
      - die Datei "reader.pref" mit dem Editor öffnen
      - den Eintrag "HORIZONTAL_MARGIN=" suchen
      jetzt kann man den Wert hinter dem "=" ändern (ich habe dort 20 eingetragen, 0 würde bedeuten, dass der Text direkt am linken Displayrand beginnt und am rechten Rand aufhört)
      - die Datei speichern und schließen
      - den Kindle korrekt vom PC trennen (Auswerfen)
      - Restart auf dem Kindle durchführen (Home --> Menu --> Settings --> Menu --> Restart)

      Somit hat man einen kleineren Rand links und rechts.
      Kleiner Nachteil dieser Einstellung: Wenn man über die Aa Taste des Kindle die Einstellung "Words per Line" ändert, dann wird die zuvor vorgenommene Einstellung in "reader.pref" überschrieben.



      Bratzzo
      "Am Ende wird alles gut! Wenn es nicht gut wird, ist es noch nicht das Ende." Oscar Wilde
      Diese Signatur wurde bereits 59 mal bearbeitet, zuletzt von »Bratzzo« (Heute, 00:23:59)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Bratzzo“ () aus folgendem Grund: Hinweis auf verstecktem Ordner

      Hi,

      Du hast versteckte Dateien auf Deinem PC ausgeblendet?
      Ich hatte vergessen zu erwähnen, dass der Ordner versteckt ist.
      Entweder Du blendest versteckte Dateien ein, oder Du suchst (auf dem Laufwerk, dem Dein Kindle zugewiesen ist) nach der Datei "reader.pref" und stellst in der Suche ein, dass auch nach versteckten Dateien gesucht werden soll.

      Denn die Datei und die Ordner gibt es auf jeden Fall, sonst hätte ich nicht die Änderungen auf meinem Kindle durchführen können.




      Bratzzo
      "Am Ende wird alles gut! Wenn es nicht gut wird, ist es noch nicht das Ende." Oscar Wilde
      Diese Signatur wurde bereits 59 mal bearbeitet, zuletzt von »Bratzzo« (Heute, 00:23:59)
      Okay, ich hatte den Haken bei versteckte Systemdateien ausblenden noch drin.
      Ich hatte nur versteckte Ordner anzeigen lassen.
      Sorry, ich hatte dich da wohl falsch verstanden.

      Die anderen Bücher werden tatsächlich anders dargestellt. Nur das "böse" Buch nicht....

      Schade...
      Im Normalfall, bei anderen Büchern ist der Rand nicht zu groß. Da bin ich mit den Standardeinstellungen des Kindle zufrieden.

      Der etwas größere Rand von ca. 1cm zusätzlich als Standard, ist nur bei einem Buch.
      Es ist "Limit" von Frank Schätzing. Das habe ich "umwandelbar" gemacht und mit Calibre zu mobi geändert.
      Habe auch versucht dabei in Calibre den linken Rand zu verkleinern. Ebenfalls ohne Erfolg.

      Zu Limit muss ich noch sagen, dass ich sowohl das Hard Cover gekauft habe. Das war mir auf Dauer zu schwer. Deshalb habe ich mir das eBook gekauft (epub+DRM). Davor habe ich das Hörbuch von Audible gehört. Das ist jedoch stark gekürzt, merke ich nun da ich es lese.

      Sorry für die schleppende Kommunikation. Bin gerade am Renovieren und habe deshalb wenig Zugriff zum Laoptop, nachdem ich es wieder gefunden habe ...
      DRM? Was ist das?
      Komisch, dann liegt es definitiv am Buch!
      Bin jetzt bereits bei 75% aufm Kindle.
      Ganz fertig gehört habe ich die Hörbuch Version nicht. Die vielen Personen sind beim Lesen leichter auseinander zu halten als beim Hören!
      Hatte davor auch den Schwarm gehört (in dem Fall ein Hörspiel, genieal!) und gelesen.
      DRM? Was ist das?
      Hi,

      Limit ist es also.
      OK, das stand auf meinem Merkzettel. Der Kauf wurde dann halt vorgezogen. ;)

      Ja, ich sehe den übermäßigen linken Rand auch. Und jetzt ist er bei mir weg!

      Dazu mussten mehrere Werte von "margin-left" von 33px auf 0px geändert werden. Zusätzlich habe ich in der Zeile darunter "margin-right" den Wert auch auf 0px geändert.

      Jetzt ist der Linke und rechte Rand auch gleichmäßig.


      Übrigens hat man den Rand auch schon beim epub gesehen. Auf dem Kindle fällt das aber eher auf als auf dem Reader auf dem PC.



      Bratzzo

      PS:
      @ Helgetus und Formel-LMS
      Ich schicke Euch gleich mal eine PM
      "Am Ende wird alles gut! Wenn es nicht gut wird, ist es noch nicht das Ende." Oscar Wilde
      Diese Signatur wurde bereits 59 mal bearbeitet, zuletzt von »Bratzzo« (Heute, 00:23:59)